Partial eCase Outage

Incident Report for eCase

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 15:48 BST

Monitoring

We have noticed some networking issues that have caused errors for some eCase customers this morning. We have been investigating and have concluded that this is due to an unresponsive server instance. We believe we have resolved the immediate issue as of 11:27am, but we are monitoring for further problems.
Posted Sep 09, 2025 - 11:45 BST
This incident affected: eCase.