Problems running bulk reports

Incident Report for eCase

Monitoring

This issue is resolved. Reports are all back in sync with the latest case changes. We will continue to monitor. Please report any further issues to support@ecase.co.uk
Posted Mar 27, 2026 - 09:33 GMT

Identified

The underlying issue has been fixed, however, there is a risk that recently updated cases may not be reflected correctly on reports. These should be back in sync shortly.
Posted Mar 26, 2026 - 13:06 GMT

Update

In the course of our investigation we have identified that the problems may also be causing issues with PDF conversion, redaction and document preview. We are continuing our investigations and will provide further updates on our status page shortly.
Posted Mar 26, 2026 - 12:14 GMT

Investigating

Some customers are experiencing problems running bulk reports. We are investigating and will update on our status page shortly.
Posted Mar 26, 2026 - 10:56 GMT
This incident affects: eCase.