Some customers are unable to log into eCase

Incident Report for eCase

Monitoring

The issue has been identified and resolved. We will continue to monitor.
Posted Dec 05, 2025 - 14:22 GMT

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 14:21 GMT

Investigating

We are aware that some customers are unable to log into eCase. We are investigating the cause.
Posted Dec 05, 2025 - 14:09 GMT
This incident affects: eCase.