Problem accessing eCase for some customers

Incident Report for eCase

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 11:16 BST

Monitoring

The problem has been identified and resolved. We are monitoring to make sure eCase is stable.
Posted Jul 03, 2025 - 08:15 BST

Investigating

We have been made aware that some customers are unable to access eCase. We are investigating.
Posted Jul 03, 2025 - 08:03 BST
This incident affected: eCase.